__webpack_require__.e is not a function

在laravel+vue的项目中,给vue使用vue-router的路由懒加载。

在router的配置文件里面。正常import没有问题

import Home from './../js/views/home.vue'                


  1. 但是只要使用路由懒加载
const Home = r => require.ensure([], () => r(require('./../js/views/home.vue')))

就会报上面的错误,不知道为啥

回答:

const Home=()=>import('./../js/views/home.vue')

试试下面这个

const Home=()=>Promise.resolve(require('./../js/views/home.vue'))

回答:

升级到了webapck3.0,使用了extract-text-webpack-plugin插件。此插件在3.0中必须配置和一个叫allChunks: true的参数

https://segmentfault.com/a/11…

暂无评论

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注