vue-loader莫名报错?

图片描述

昨天做的测试项目本来好好的,把里边的文件复制到另一个文件夹,在启动就报错了?

Error: [vue-loader] vue-template-compiler must be installed as a peer dependency, or a compatible compiler implementation must be passed via options.

上面说要安装一个同等的依赖,又没有说是哪个具体的依赖,感觉非常莫名其妙?

回答:

重新npm install vue-template-compiler -D就行

回答:

有更加全的报错信息么?

Emmmm,你可以看一下你的vue版本和vue-template-compiler版本是否一致。

回答:

这个错误一般情况下是在vue版本和vue-template-compiler版本不一致的情况下才会报出;
例如你输入如下命令更新vue版本时

npm install --save vue

如图所示:
图片描述

vue的版本是2.5.22,vue-template-compiler的版本是2.5.21
你所要做的就是保持相关版本一致。

npm install --save-dev vue-template-compiler@版本号 # vue-template-compiler版本号与vue的版本号一致

回答:

有复制node_module文件夹么?如果有。删掉直接npm install

暂无评论

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注