vue的pc端兼容性如何?

vue的pc端浏览器兼容性都有什么坑?
我看官网上说的是支持es6的浏览器vue都支持,请问有实际开发中用vue的项目吗,各个浏览器表现如何?

回答:

官网上的两句话描述了其兼容性

clipboard.png

回答:

VUE做PC端项目最适合的还是公司的OA系统,毕竟可以规定员工用的浏览器等,因为现在不排除有部分用户使用IE8-的可能性,如果排除这些不谈,VUE主要开始开发单页面应用,单页面对于SEO也是极其不友好的,因此最多还是用在了手机端SPA和后台OA上面。

回答:

IE9及以上浏览器,所以chrome,firefox更是没有问题,只要支持ES5特性的浏览器均可

回答:

我现在的项目(银行的系统)使用的是angular1.2.32版本,完美兼容ie8,这还是努力争取不兼容更低的ie情况下,当然,系统不考虑seo。好像在这提angular不合适

回答:

这些框架最终都会被转成es5,是可以在主流浏览器运行的。
vue比较特殊,因为它使用的是对象的getter,setter。这些特性ie9以上才支持,其他非ie系浏览器基本都支持

回答:

参考官网https://cn.vuejs.org/v2/guide…

Vue.js 不支持 IE8 及其以下版本,因为 Vue.js 使用了 IE8 不能模拟的 ECMAScript 5 特性。Vue.js 支持所有兼容 ECMAScript 5 的浏览器。

回答:

但是我用Edge好像有点问题,当一个list长度为0时,一个div不显示,但我用Edge打开的时候,它还是显示了

回答:

vue-router的history模式,在IE9下不兼容

回答:

只要浏览器支持 Object.defineProperty 这个方法,vue 就能运行起来,这个方法没有也不可能有兼容脚本,而 IE8 以下的没有这个方法,所以支持不了。

在浏览器控制台执行就可以查看有没有这个方法。

暂无评论

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注